Delayed Crypto Deposits

Incident Report for Coinsquare

Resolved

This incident has been resolved.
Posted Jul 26, 2026 - 14:00 EDT

Investigating

We're investigating reports of delays in crypto deposits being credited to account balances. Some users may see their deposit confirmed on the blockchain but not yet reflected in their account balance. We're looking into the cause and will provide an update shortly.
Posted Jul 26, 2026 - 12:47 EDT
This incident affected: Digital Currency Deposits.